Support Custom Remote Controller

To support custom remote controller with LIRC, your kernel version should be 3.14.29-56 (2016/04/20) or higher.
This functionality is only available with Ubuntu.

(update 2018.06.25)
LIRC version of Ubuntu 18.04 is higher than Ubuntu 16.04 and related files under /etc/lirc/ are configured differently.
Select your Ubuntu version first among the following guides.

Support Custom Remote Controller with Ubuntu 16.04

Support Custom Remote Controller with Ubuntu 18.04